


ค าน า 

หนงัสอื “การเรยีนรูภ้าษา C++ ดว้ย Dev-C++” เล่มนี้ ไดร้บัการออกแบบมาเพื่อตอบสนองความ
ตอ้งการของผูเ้ริม่ตน้ทีไ่ม่มพีืน้ฐานการเขยีนโปรแกรมมาก่อน รวมถงึผูท้ ีต่อ้งการวางรากฐานทีม่ ัน่คงใน
การเขยีนโปรแกรมดว้ยภาษา C++ โดยเน้นการเรยีนรูผ้า่นโปรแกรม Dev-C++ ซึง่ใชง้านง่าย เหมาะ
ส าหรบัผูเ้ริม่ตน้ทุกระดบั 

ในระดบั � ผูเ้ริม่ตน้ (Beginner Level) ผูอ่้านจะไดร้บัความรูแ้ละทกัษะทีจ่ าเป็นต่อการเริม่ตน้พฒันา
โปรแกรม C++ อยา่งเป็นระบบ โดยเนื้อหาครอบคลุม 5 หวัขอ้หลกั ดงันี้: 

1. พื้นฐานการใช้งาน Dev-C++ 
เริม่ตน้จากการตดิตัง้และตัง้ค่าโปรแกรม Dev-C++ การสรา้งและคอมไพลโ์ปรเจกตแ์รก พรอ้ม
ท าความเขา้ใจส่วนประกอบของโปรแกรม C++ เช่น main() และ #include รวมถงึเขยีน
โปรแกรมง่าย ๆ อยา่ง Hello World! 

2. พื้นฐานภาษา C++ 
เรยีนรูก้ารประกาศตวัแปรและชนิดขอ้มลูพืน้ฐาน เชน่ int, float, char, bool รวมถงึการรบั-
แสดงค่าดว้ย cin และ cout และการใชต้วัด าเนินการทางคณิตศาสตรแ์ละลอจกิ เช่น +, -, *, /, 
++, -- 

3. โครงสร้างควบคมุโปรแกรม 
ฝึกการเขยีนโปรแกรมโดยใชค้ าส ัง่ควบคุมทศิทางของโปรแกรม เชน่ if, else if, else, switch-
case และการวนลปูดว้ย for, while, do-while พรอ้มค าส ัง่พเิศษอยา่ง break และ continue 

4. ฟังกช์นัพื้นฐาน 
อธบิายการสรา้งและเรยีกใชง้านฟังกช์นั ทัง้แบบ void และแบบทีส่ง่ค่ากลบัดว้ย return พรอ้ม
การส่งค่าดว้ยพารามเิตอร ์เพื่อเสรมิสรา้งความเขา้ใจในการแยกส่วนของโปรแกรม 

5. อาเรย ์(Array) และสตริง (String) 
แนะน าการใชอ้าเรยท์ ัง้แบบ 1 มติแิละ 2 มติ ิการวนลปูผา่นขอ้มลูในอาเรย ์และการใชง้านสาย
อกัขระดว้ย string จากไลบราร ี<string> ซึง่เป็นพืน้ฐานส าคญัส าหรบัการจดัการขอ้มลูจ านวน
มากและขอ้ความ 

เนื้อหาในแต่ละบทถูกออกแบบใหม้ตีวัอยา่งโคด้พรอ้มค าอธบิายโดยละเอยีด และแบบฝึกหดัเพื่อเสรมิ
ทกัษะการคดิวเิคราะหแ์ละการลงมอืปฏบิตัจิรงิ ผูอ่้านสามารถเรยีนรูแ้ละพฒันาตนเองไปทลีะข ัน้ไดอ้ยา่ง
มัน่ใจ 
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บทท่ี 1 
พ้ืนฐานการใช้งาน Dev-C++ 

(Dev-C++ Basic) 
 

เน้ือหา 

 Dev-C++ คอือะไร? 
 ประวตัขิอง Dev-C++ 
 ขดีความสามารถของ Dev-C++ 
 แนวโน้มในปัจจุบนัของ Dev-C++ 
 ขัน้ตอนการตดิตัง้และตัง้ค่า Dev-C++ 
 ขัน้ตอนการสรา้งและคอมไพลโ์ปรเจกตแ์รกใน Dev-C++ 
 การตดิตัง้และตัง้ค่า Dev-C++ (2) 
 ส่วนประกอบของโปรแกรม C++ เบือ้งตน้ 
 การเขยีนโปรแกรม Hello World! ใน Dev-C++ 

 
  

บทน า 
ภาษา C++ เป็นหนึ่งในภาษาการเขยีนโปรแกรมระดบัสงูทีม่คีวามยดืหยุน่และทรงพลงั ไดร้บัความนิยม
อย่างแพร่หลายในวงการวศิวกรรมซอฟต์แวร์ การพฒันาระบบฝังตวั และการสร้างแอปพลเิคชนัที่
ตอ้งการประสทิธภิาพสงู หนงัสอืเล่มนี้มุ่งเน้นการปพูืน้ฐานใหผู้อ่้านสามารถเริม่ตน้เรยีนรูภ้าษา C++ ได้
อยา่งเป็นระบบ โดยเริม่จากการใชง้าน Dev-C++ ซึง่เป็นโปรแกรมพฒันา (IDE) ทีเ่หมาะสมกบัผูเ้ริม่ตน้ 
มอีนิเทอรเ์ฟซทีใ่ชง้านง่ายและสนบัสนุนการเขยีนโปรแกรม C++ ไดอ้ยา่งครบถ้วน 

ในบทแรก ผู้อ่านจะได้เรยีนรู้ข ัน้ตอนการตดิตัง้และตัง้ค่าโปรแกรม Dev-C++ ตัง้แต่การดาวน์
โหลดไฟล์ติดตัง้ การเลือกเวอร์ชนัที่เหมาะสม ไปจนถึงการตัง้ค่าพื้นฐานที่จ าเป็นในการเริ่มเขยีน
โปรแกรม ทัง้นี้เพื่อใหเ้ครื่องมอืทีใ่ชง้านพรอ้มส าหรบัการพฒันาโปรแกรมอยา่งราบรื่น โดยไม่ตดิขดัทาง
เทคนิค 

ต่อจากนัน้ ผู้อ่านจะได้ฝึกการสร้างโปรเจกต์ใหม่ใน Dev-C++ และทดลองคอมไพล์โปรแกรม 
C++ แรกของตนเอง พรอ้มท าความเขา้ใจองคป์ระกอบหลกัของโปรแกรม C++ เช่น ฟังกช์นั main() ซึ่ง
เป็นจุดเริม่ตน้ของการท างานของโปรแกรม และไฟล์ส่วนหวั (header files) ที่มบีทบาทในการประกาศ
ฟังกช์นัและการน าเขา้ไลบรารต่ีาง ๆ ทีจ่ าเป็น 
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สุดทา้ย เพื่อสรา้งความมัน่ใจและแรงจงูใจในการเรยีนรู ้ผูอ่้านจะไดท้ดลองเขยีนโปรแกรมง่าย ๆ 
อยา่ง “Hello World!” ซึง่ถอืเป็นจุดเริม่ตน้ส าคญัของการเขยีนโปรแกรมในหลายภาษา โค้ดโปรแกรมนี้
จะช่วยใหผู้อ่้านเขา้ใจรูปแบบพื้นฐานของภาษา C++ และกระบวนการท างานตัง้แต่เขยีนโปรแกรมไป
จนถึงการแสดงผลลพัธ์บนหน้าจอ ทัง้นี้เพื่อให้ผู้อ่านพร้อมส าหรบัการเรยีนรู้ ในระดบัที่ลึกขึน้ในบท
ถดัไป. 

 
✅ Dev-C++ คืออะไร? 
Dev-C++ เป็น Integrated Development Environment (IDE) ส าหรบัภาษา C และ C++ ทีไ่ดร้บั
ความนิยมมาก โดยเฉพาะในหมู่นกัเรยีน นกัศกึษา และผูเ้ริม่ตน้เรยีนรูก้ารเขยีนโปรแกรมภาษา C/C++ 
เนื่องจากใชง้านง่ายและไม่ซบัซอ้น 

 
✅ คณุสมบติัหลกัของ Dev-C++ 

 สนบัสนุนภาษา C และ C++ 
 ใชง้านกบั MinGW (Minimalist GNU for Windows) compiler 
 ม ีsyntax highlighting และ code completion 
 รองรบั การ debug เบือ้งต้น 
 มรีะบบสรา้งโปรเจกต ์และจดัการไฟลโ์คด้หลายไฟลใ์นโครงการเดยีว 
 ใชพ้ืน้ทีน้่อย ตดิตัง้ง่าย 

 
✅ เวอรช์นัท่ีรู้จกักนัมาก: 

 Dev-C++ ของ Bloodshed (รุ่นดัง้เดมิ): หยดุพฒันาไปนานแลว้ 
 Embarcadero Dev-C++ (รุ่นใหม่): ไดร้บัการพฒันาและอปัเดตใหร้องรบั Windows 10/11 

และมาตรฐาน C++ ล่าสุด (เชน่ C++11, C++14, C++17) 

 
✅ จดุเด่น: 

 เหมาะส าหรบัผูเ้ริม่ตน้ 
 ตดิตัง้ง่าย ใชง้านไม่ยุง่ยาก 
 ฟรแีละโอเพ่นซอรส์ 

⚠  ข้อจ ากดั: 
 ฟีเจอรน้์อยเมื่อเทยีบกบั IDE สมยัใหม่อยา่ง Visual Studio, Code::Blocks, หรอื CLion 
 ไม่เหมาะกบัโปรเจกตข์นาดใหญ่หรอืการพฒันาเชงิพาณชิยใ์นระดบัสงู 
 ไม่ม ีIntelliSense หรอืระบบ debug ทีซ่บัซอ้น 

 

https://www.embarcadero.com/free-tools/dev-cpp
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หากคุณตอ้งการตวัอยา่งโคด้ใน Dev-C++ หรอืค าแนะน าการใชง้าน เช่น การตดิตัง้ การเขยีนโปรแกรม
แรก (Hello World) หรอืการใชฟั้งกช์นัต่าง ๆ กส็ามารถขอไดเ้ลยครบั! 
ไดเ้ลยครบั! ต่อไปนี้คอื ประวติัของ Dev-C++ ตัง้แต่เริม่ตน้จนถงึเวอรช์นัล่าสุด: 

 
✅ ประวติัของ Dev-C++ 
✅ จดุเร่ิมต้น: Bloodshed Dev-C++ 

 Dev-C++ ถูกสรา้งขึน้ครัง้แรกโดยนกัพฒันาชาวอติาลชีื่อ Colin Laplace ภายใตช้ื่อทมีวา่ 
Bloodshed Software 

 เริม่ตน้พฒันาประมาณปี 1998–1999 
 เป็น IDE ทีอ่อกแบบมาเพื่อภาษา C/C++ โดยใช ้MinGW (Minimalist GNU for Windows) 

เป็น compiler หลกั 
 กลายเป็นทีน่ิยมอยา่งมากในหมูน่กัเรยีนและผูเ้ริม่ตน้ เพราะเป็นโปรแกรมฟร ีขนาดเลก็ ใชง้าน

ง่าย 
✅ จดุหยดุพฒันา 

 การพฒันาโดย Bloodshed หยดุไปช่วงปี 2005–2006 
 รุ่นสุดทา้ยของ Bloodshed Dev-C++ คอื Dev-C++ 4.9.9.2 
 แมจ้ะหยดุพฒันา แต่กย็งัมผีูใ้ชง้านจ านวนมากใชต่้อเนื่อง 

 
✅ การคืนชีพ: Orwell Dev-C++ 

 ในปี 2011 นกัพฒันาชื่อ Johan Mes (ใช้นามแฝงว่า Orwell) ไดท้ าการ "fork" โครงการและ
พฒันา Dev-C++ ขึน้มาใหม่ในชื่อ Orwell Dev-C++ 

 ปรบัปรุง: 
o รองรบัมาตรฐาน C++11 
o อปัเดต MinGW compiler 
o ปรบั UI และแกบ้ัก๊จ านวนมาก 

 รุ่นทีรู่จ้กักนัดจีาก Orwell คอืเวอรช์นั 5.x 

 
✅ เวอรช์นัล่าสดุ: Embarcadero Dev-C++ 

 ปี 2020 บรษิทั Embarcadero Technologies (บรษิทัเดยีวกบัผูพ้ฒันา Delphi) ไดเ้ขา้มาสาน
ต่อ Dev-C++ อกีครัง้ 

 พฒันาและรแีบรนดใ์นชื่อวา่ Embarcadero Dev-C++ 
 จุดเด่นของเวอรช์นันี้: 

o รองรบั C++17 
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o สนบัสนุนการท างานบน Windows 10/11 
o รองรบั DPI scaling ส าหรบัจอความละเอยีดสงู 
o มรีะบบการจดัการโปรเจกตด์ขี ึน้ และปรบัปรุง UI 

 
  สรปุเวอรช์นัหลกั 

ยคุ ผู้พฒันา ช่ือเวอรช์นั ปีท่ีพฒันา สถานะ 

เริม่ตน้ Bloodshed (Colin Laplace) Dev-C++ 4.x ~1999–2005 หยดุพฒันา 

กลาง Orwell (Johan Mes) Dev-C++ 5.x 2011–2015 หยดุพฒันา 

ปัจจุบนั Embarcadero Embarcadero Dev-C++ 2020–ปัจจุบนั ยงัพฒันาอยู ่

 
✅ หมายเหตเุพ่ิมเติม 

 ปัจจุบนัแม ้Dev-C++ จะยงัมผีูใ้ชง้านอยู ่แต่ IDE สมยัใหม่อยา่ง Visual Studio Code, 
Code::Blocks, หรอื CLion กเ็ริม่มาแทนทีใ่นหลายภาคการศกึษา 

 อยา่งไรกต็าม Dev-C++ กย็งัเหมาะมากส าหรบัผูท้ ีต่อ้งการ IDE ขนาดเลก็ ท างานรวดเรว็ และ
ไม่ซบัซอ้น 

 
✅ ขีดความสามารถของ Dev-C++ 
แมจ้ะเป็น IDE ทีเ่รยีบง่าย แต่ Dev-C++ กม็ขีดีความสามารถเพยีงพอส าหรบัการเรยีนรูแ้ละพฒันา
โปรแกรมพืน้ฐานในภาษา C/C++ ไดอ้ยา่งสะดวก โดยมคีวามสามารถหลกัดงันี้: 
✅ 1. รองรบัภาษา C และ C++ 

 สนบัสนุนมาตรฐานภาษา C89, C99 และ C++98/03 
 เวอรช์นัใหม ่(Embarcadero) รองรบั C++11, C++14 และ C++17 

✅ 2. การรวมกบั Compiler (MinGW) 
 ใช ้MinGW (Minimalist GNU for Windows) เป็น Compiler หลกั 
 สามารถแยกตดิตัง้หรอืเลอืก compiler เองได ้

✅ 3. Code Editor ท่ีใช้งานง่าย 
 Syntax Highlighting (ไฮไลตค์ าส ัง่) 
 Auto-completion (เตมิค าอตัโนมตัริะดบัเบือ้งตน้) 
 Bracket matching (ไฮไลตว์งเลบ็เปิด-ปิด) 
 Multiple tabs (เปิดหลายไฟลพ์รอ้มกนัได)้ 

✅ 4. Project Management 
 รองรบัการสรา้งโปรเจกต ์
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 เพิม่/ลบไฟลใ์นโปรเจกตไ์ดส้ะดวก 
 แยกไฟล ์header และ source อยา่งชดัเจน 

✅ 5. การ Debug เบือ้งต้น 
 มรีะบบ Debug ในตวั (แมไ้มส่มบรูณ์แบบ) 
 Breakpoint, Step Over, Watch variables (จ ากดั) 

✅ 6. เครื่องมือเสริม 
 Makefile Generator (ในบางเวอรช์นั) 
 การจดัการกบั Templates 
 ค าสัง่ Compile/Build/Run อยา่งรวดเรว็ 
 รองรบั Command-line Arguments 

✅ 7. ฟรีและเบา 
 ท างานรวดเรว็ ใชท้รพัยากรน้อย 
 เหมาะกบัเครื่องสเปกต ่า/เก่า 

 
✅ แนวโน้มในปัจจบุนัของ Dev-C++ 
✅ ยงัมีการใช้งานอยู่โดยเฉพาะใน: 

1. การศึกษา 
o วทิยาลยั มหาวทิยาลยัหลายแห่งในไทยและต่างประเทศยงัใช ้Dev-C++ ในการสอน

เบือ้งตน้ 
o เหมาะส าหรบั Intro to C/C++ courses เพราะใชง้านง่าย ตดิตัง้ง่าย 

2. ผู้เร่ิมต้น (Beginner Level) 
o ผูท้ีเ่พิง่เริม่เขยีนโปรแกรมชื่นชอบเพราะไมซ่บัซอ้น 

 
✅ แต่แนวโน้มทัว่ไปคือเร่ิม ถกูแทนท่ีด้วยเครื่องมือท่ีทนัสมยักว่า เช่น: 

IDE จดุเด่น 

Visual Studio Code (VS 
Code) 

ม ีExtension รองรบั C/C++, IntelliSense, Debugger เตม็รปูแบบ 

Code::Blocks ใชง้านคลา้ย Dev-C++ แต่มฟีีเจอรค์รบกวา่ 

CLion (JetBrains) 
IDE เชงิพาณิชยท์ีท่รงพลงัมาก รองรบั CMake, Debug, Refactor 
อยา่งมอือาชพี 

Visual Studio ส าหรบั Windows โดยตรง ม ีdebugger และ GUI แบบครบเครื่อง 
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✅ ข้อสรปุ 

จดุแขง็ของ Dev-C++ ข้อจ ากดั 

ใชง้านง่าย เหมาะกบัผูเ้ริม่ตน้ ไม่รองรบัมาตรฐาน C++ ล่าสุดทัง้หมด 

ใชท้รพัยากรน้อย ระบบ Debug ไมส่มบรูณ์แบบ 

ฟรแีละตดิตัง้รวดเรว็ ไม่มรีะบบ IntelliSense ข ัน้สงู 

รองรบัการเขยีนโปรแกรมพืน้ฐานไดด้ ีไม่เหมาะกบัโปรเจกตร์ะดบัใหญ่หรอืซบัซอ้น 

 
  ขัน้ตอนการติดตัง้และตัง้ค่า Dev-C++ 
✅ 1. ดาวน์โหลด Dev-C++ 
เวอรช์นัแนะน า: Embarcadero Dev-C++ 
� ดาวน์โหลดไดท้ี:่ 
� https://www.embarcadero.com/free-tools/dev-cpp 
หรอืถ้าคุณใชเ้วอรช์นั Orwell Dev-C++ (เบากวา่): 
� https://sourceforge.net/projects/orwelldevcpp/ 

 
✅ 2. ติดตัง้โปรแกรม 

1. ดบัเบลิคลกิทีไ่ฟล ์.exe ทีด่าวน์โหลดมา 
2. เลอืกภาษา (ส่วนใหญ่เลอืก English) 
3. กด Next ไปตามขัน้ตอนจนถงึหน้าต่าง License Agreement 
4. กด I Agree, จากนัน้เลอืกโฟลเดอรส์ าหรบัตดิตัง้ (เชน่ C:\Dev-Cpp) 
5. กด Install 
6. เมื่อตดิตัง้เสรจ็ ใหค้ลกิ Finish 

 
✅ 3. เปิดใช้งานคร ัง้แรก และตัง้ค่าเบือ้งต้น 

1. เมื่อเปิดโปรแกรมครัง้แรก จะมหีน้าต่างใหเ้ลอืก: 
o Compiler → แนะน าใหใ้ช ้TDM-GCC 9.x หรอื MinGW64 
o ภาษา: เลอืก English หรอื Thai ตามสะดวก 

2. ตรวจสอบวา่โปรแกรมมองเหน็ Compiler: 
o ไปที ่Tools > Compiler Options 
o ทีแ่ทบ็ "Compiler Set to configure" ควรแสดงรายการเช่น TDM-GCC, MinGW, 

หรอืชื่อ compiler อื่น 
o หากไม่ม ีใหด้าวน์โหลด MinGW แยกแลว้ตดิตัง้ใหม่ (จะอธบิายเพิม่ถ้าตอ้งการ) 

https://www.embarcadero.com/free-tools/dev-cpp
https://sourceforge.net/projects/orwelldevcpp/
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✅ 4. สร้างโปรเจกตแ์รก (Hello World) 

1. ไปที ่File > New > Source File 
2. พมิพโ์คด้ต่อไปนี้: 

#include <iostream> 
using namespace std; 
 
int main() { 
    cout << "Hello, world!" << endl; 
    return 0; 
} 

3. กด Ctrl + S เพื่อบนัทกึไฟล ์เชน่ hello.cpp 
4. ไปที ่Execute > Compile & Run หรอืกดปุ่ม F11 
5. หน้าต่าง Console จะเปิดขึน้พรอ้มแสดง: 

Hello, world! 

 
✅ 5. การตัง้ค่าพื้นฐานอ่ืน ๆ (แนะน า) 

การตัง้ค่า วิธีการ 

ปรบัขนาด Font Tools > Editor Options > Fonts 

เปิด Line Number Tools > Editor Options > General > Show Line Numbers 

ตัง้ค่า Auto Save Tools > Environment Options > Files 

ตัง้ค่าการใชแ้ทบ็แทนช่องวา่ง Tools > Editor Options > Indentation 

 
⚠  ปัญหาท่ีพบบ่อย 

ปัญหา วิธีแก้ 

Compile แลว้ม ีerror วา่ "g++.exe 
not found" 

ไปที ่Tools > Compiler Options ตรวจสอบวา่ compiler path 
ถูกตอ้ง 

Run แลว้ Console ปิดเรว็เกนิไป ใส ่system("pause"); หรอื run จาก Command Prompt แทน 

พมิพภ์าษาไทยแลว้เป็นภาษาต่าง
ดาว 

เปลีย่น Font ใน Editor เป็น Tahoma หรอื Consolas และตัง้ 
encoding เป็น UTF-8 
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  ขัน้ตอนการสร้างและคอมไพลโ์ปรเจกต์แรกใน Dev-C++ 

 
✅ ขัน้ตอนท่ี 1: เปิด Dev-C++ และสร้างโปรเจกตใ์หม่ 

1. เปิดโปรแกรม Dev-C++ 
2. ไปทีเ่มนู File > New > Project... 
3. จะปรากฏหน้าต่าง “New Project” 
4. เลอืกประเภทโปรเจกต:์ 

o เลอืก "Console Application" 
o เลอืกภาษาเป็น C++ 

5. กด OK 

 
✅ ขัน้ตอนท่ี 2: ตัง้ช่ือโปรเจกตแ์ละก าหนดต าแหน่ง 

1. ในหน้าต่าง "Create New Project": 
o ใส่ชื่อโปรเจกต ์เช่น HelloProject 
o เลอืกโฟลเดอรส์ าหรบัเกบ็โปรเจกต ์เช่น 

C:\Users\YourName\Documents\DevCpp\HelloProject 
2. คลกิ Save 

� Dev-C++ จะสรา้งไฟล ์.dev และโฟลเดอรโ์ปรเจกตใ์หโ้ดยอตัโนมตั ิ

 
✅ ขัน้ตอนท่ี 3: เขียนโค้ดโปรแกรมแรก 
Dev-C++ จะเปิดไฟล ์main.cpp มาใหโ้ดยอตัโนมตั ิคณุสามารถแกไ้ขใหเ้ป็นโคด้ตวัอยา่งดา้นล่าง: 
#include <iostream> 
using namespace std; 
 
int main() { 
    cout << "Hello, Dev-C++!" << endl; 
    return 0; 
} 
� อยา่ลมืกด Ctrl + S เพื่อบนัทกึไฟล ์

 
✅ ขัน้ตอนท่ี 4: คอมไพลแ์ละรนัโปรแกรม 

1. กดปุ่ม F11 หรอืไปทีเ่มนู Execute > Compile & Run 
2. Dev-C++ จะท าการ Compile โคด้ และเปิดหน้าต่าง Console ขึน้มา 
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3. คุณจะเหน็ขอ้ความ: 
Hello, Dev-C++! 
� แสดงวา่โปรแกรมท างานไดเ้รยีบรอ้ยแลว้! 

 
✅ ค าสัง่ Compile ท่ีควรรู ้

ค าสัง่ ความหมาย คียล์ดั 

Compile แปลโปรแกรมเป็นไฟล ์.exe แต่ยงัไม่รนั Ctrl + F9 

Run รนัไฟล ์.exe ทีค่อมไพลแ์ลว้ Ctrl + F10 

Compile & Run แปลและรนัในขัน้ตอนเดยีว F11 

 
✅ เคลด็ลบัเพ่ิมเติม 

 � อยา่ลมืบนัทกึไฟลบ่์อยๆ (กด Ctrl + S) 
 � หาก Console ปิดเรว็เกนิไป ใหเ้พิม่ค าส ัง่: 
 system("pause"); 
 � หากโปรเจกตม์หีลายไฟล ์(เช่น .cpp, .h) สามารถคลกิขวาที ่"Project" > "Add to project" 

เพื่อเพิม่ไฟลไ์ด ้

 
✅ ตวัอย่างโปรเจกต ์Hello Calculator (เสริม) 
#include <iostream> 
using namespace std; 
 
int main() { 
    int a, b; 
    cout << "Enter two numbers: "; 
    cin >> a >> b; 
    cout << "Sum = " << (a + b) << endl; 
    return 0; 
} 
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  การติดตัง้และตัง้ค่า Dev-C++ (2) 
1. ดาวน์โหลดโปรแกรม 

ไปทีเ่วบ็ของ Embarcadero Dev-C++ (หรอืเลอืก Orwell ของ SourceForge กไ็ด)้ และดาวน์
โหลดเวอรช์นัล่าสุด เช่น 6.x (embarcadero.com) 

2. **เปิดโปรแกรมตดิตัง้** 
ดบัเบลิคลกิไฟลต์ดิตัง้ เช่น devcpp-6.3.setup.exe 
เลอืกภาษา → กด “OK” (reddit.com, programmingzona.blogspot.com) 

3. ยอมรบัข้อตกลง 
เลอืก “I Agree” เพื่อต่อไป (ultahost.com, programmingzona.blogspot.com) 

4. เลือก Components 
เลอืก “Full installation” เพื่อใหไ้ด ้IDE + MinGW compiler ตามค่าเริม่ตน้ 
(programmingzona.blogspot.com) 

5. ก าหนดท่ีเกบ็ไฟล ์
โปรแกรมจะแนะน าโฟลเดอรเ์ช่น C:\Dev-Cpp หรอื Program Files\Dev-C++ กด Next และ 
Install (youtube.com, programmingzona.blogspot.com) 

6. ติดตัง้เสรจ็ส้ิน 
เลอืก “Run Dev-C++” แลว้กด Finish (begincpp.blogspot.com) 

7. ตัง้ค่าเบือ้งต้น 
o ตรวจสอบคอมไพเลอรท์ี ่Tools → Compiler Options 
o ตัง้ค่าฟอนต ์และเปิดเลขบรรทดัที ่Tools → Editor Options 
o ตัง้ auto-save และ tab/space ตามชอบ 

 
✅ สร้างและคอมไพลโ์ปรเจกตแ์รก (Hello World) 

1. **สรา้งโปรเจกตใ์หม่** 
ไปที ่File → New → Project... 
เลอืก Console Application > C++ Project (technologyuk.net, cs.uno.edu) 
ตัง้ชื่อ เช่น HelloProject และเลอืกโฟลเดอรเ์กบ็ไฟล ์

2. เขียนโค้ดในไฟล ์main.cpp 
ลบโคด้เดมิ (ถ้าม)ี และพมิพ:์ 

3. #include <iostream> 
4. using namespace std; 
5.  
6. int main() { 

https://www.embarcadero.com/free-tools/dev-cpp/free-download?utm_source=chatgpt.com
https://www.reddit.com/r/CodingHelp/comments/1dqjbse/setting_up_for_cc_development/?utm_source=chatgpt.com
https://programmingzona.blogspot.com/2009/07/step-by-step-installation-of-dev-c-with.html?utm_source=chatgpt.com
https://ultahost.com/knowledge-base/install-dev-c-plus-windows/?utm_source=chatgpt.com
https://programmingzona.blogspot.com/2009/07/step-by-step-installation-of-dev-c-with.html?utm_source=chatgpt.com
https://programmingzona.blogspot.com/2009/07/step-by-step-installation-of-dev-c-with.html?utm_source=chatgpt.com
https://www.youtube.com/watch?v=jfVRap6hQWI&utm_source=chatgpt.com
https://programmingzona.blogspot.com/2009/07/step-by-step-installation-of-dev-c-with.html?utm_source=chatgpt.com
https://begincpp.blogspot.com/2009/07/install-dev-c.html?utm_source=chatgpt.com
https://www.technologyuk.net/software-development/computer-programming/cpp-programming/getting-started-with-dev-c%2B%2B.shtml?utm_source=chatgpt.com
https://cs.uno.edu/~jaime/Courses/2025/devCpp2025Instructions.html?utm_source=chatgpt.com
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7.     cout << "Hello, Dev-C++!" << endl; 
8.     return 0; 
9. } 
10. บนัทึกไฟล ์

กด Ctrl + S (ระบบจะตัง้ชื่อไฟล ์main.cpp ใหโ้ดยอตัโนมตั)ิ 
11. คอมไพลแ์ละรนั 

กด F11 หรอืเลอืก Execute → Compile & Run โปรแกรมจะ compile และเปิดหน้าต่าง 
console แสดงผล: 

12. Hello, Dev-C++! 
13. เรียนรู้ค าสัง่เพ่ิมเติม 

o Ctrl + F9: Compile เท่านัน้ 
o Ctrl + F10: Run เท่านัน้ 
o F11: Compile & Run 

14. กรณี console ปิดเรว็เกินไป 
เพิม่บรรทดั system("pause"); ก่อน return 0; หรอืรนัจาก Command Prompt เพื่อดผูลลพัธ ์

 
✅ สรปุขัน้ตอน 

ขัน้ตอน รายละเอียด 

ดาวน์โหลด จากเวบ็ไซต ์Embarcadero หรอื SourceForge 

ตดิตัง้ เลอืก Full install, ตัง้ค่าภาษา, ทีเ่กบ็ไฟล ์

ตัง้ค่า IDE ตรวจสอบคอมไพเลอร,์ ปรบัฟอนต์, Auto-save 

สรา้งโปรเจกต ์ เลอืก Console/C++ Project, ตัง้ชื่อ 

เขยีนโคด้ พมิพ ์Hello World บนัทกึ 

คอมไพล ์& รนั ใช ้F11 หรอืเมนู Execute 

 
✅ ส่วนประกอบของโปรแกรม C++ เบือ้งต้น 
#include <iostream>  // (1) Header file 
 
using namespace std; // (2) Namespace 
 
int main() {         // (3) main function 
    cout << "Hello, C++!" << endl;  // (4) ค าส ัง่แสดงผล 
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    return 0;        // (5) คนืค่ากลบัไปยงัระบบปฏบิตักิาร 
} 

 
✅ (1) Header File 
#include <iostream> 

 คอืไฟลท์ีใ่ชส้ าหรบัน าเขา้ฟังกช์นัหรอืวตัถุทีจ่ าเป็นจากมาตรฐานภาษา C++ 
 <iostream> ยอ่มาจาก input-output stream ใชส้ าหรบัการแสดงผล (เช่น cout) และรบัค่า

จากคยีบ์อรด์ (เช่น cin) 
� ค าส ัง่ทีข่ ึน้ตน้ดว้ย #include เป็น Preprocessor Directive (ค าส ัง่ใหโ้ปรแกรมเตรยีมความพรอ้ม
ก่อนการคอมไพล)์ 

 
✅ (2) Namespace 
using namespace std; 

 std คอืชื่อของ standard namespace ทีร่วบรวมฟังกช์นัและวตัถุจาก C++ มาตรฐาน 
 cout, cin, endl อยูใ่น std 
 ถ้าไมใ่ส่บรรทดันี้ ตอ้งเขยีนเตม็วา่ std::cout, std::endl 

� เป็นตวัช่วยใหโ้คด้กระชบัขึน้ แต่ในระบบขนาดใหญ่ มกันิยมไมใ่ช ้using namespace std; เพราะ
อาจชนกบั namespace อื่น 

 
✅ (3) main() Function 
int main() { 
    ... 
    return 0; 
} 

 เป็นจุดเริม่ตน้ของโปรแกรม C++ 
 คอมไพเลอรจ์ะเริม่ท างานจากฟังกช์นั main() ก่อนเสมอ 
 ตอ้งมอียูใ่นทุกโปรแกรม ไมส่ามารถละเวน้ได ้

int main() 
 หมายถงึ ฟังกช์นันี้จะ ส่งค่ากลบัเป็นจ านวนเตม็ (int) 
 return 0; บ่งบอกวา่การท างานส าเรจ็ 

 
✅ (4) ค าสัง่ภายใน main(): การแสดงผล 
cout << "Hello, C++!" << endl; 

 cout = console output = ใชแ้สดงผลขอ้ความออกทางหน้าจอ 
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 << = operator ส าหรบัส่งขอ้ความไปยงั cout 
 "Hello, C++!" = string ทีจ่ะแสดง 
 endl = ขึน้บรรทดัใหม่ (เหมอืน \n) 

 
✅ (5) ค าสัง่ return 
return 0; 

 ส่งค่ากลบัไปยงัระบบปฏบิตักิาร 
 0 แปลวา่ไม่มขีอ้ผดิพลาด 
 ถ้าไม่เขยีน return กจ็ะถอืวา่คนืค่า 0 โดยปรยิาย (เฉพาะใน C++ เวอรช์นัใหม่) 

 
✅ ตวัอย่างโปรแกรม C++ ท่ีสมบรูณ์ 
#include <iostream>     // ใชง้าน cout, cin 
using namespace std;    // ใชง้าน std โดยไม่ตอ้งพมิพเ์ตม็ 
 
int main() { 
    int a, b; 
    cout << "Enter two numbers: "; 
    cin >> a >> b;  // รบัค่าจากผูใ้ช ้
    int sum = a + b; 
    cout << "Sum = " << sum << endl; 
    return 0; 
} 

 
✅ สรปุ: ส่วนประกอบส าคญัของโปรแกรม C++ 

ส่วน ค าอธิบาย 

#include น าเขา้ header files 

using namespace std; เรยีกใช ้std namespace 

main() จุดเริม่ตน้ของโปรแกรม 

cout แสดงผล 

cin รบัค่าจากผูใ้ช ้

return 0; ส่งค่าสถานะการท างานกลบัระบบ 

 



ศูนยห์นงัสือราคานกัเรียน 

 

Dev-C++ Programming : Beginner หน้า 14 

 

✅ การเขียนโปรแกรม Hello World! ใน Dev-C++ 
✅ ข ัน้ตอนท่ี 1: เปิดโปรแกรม Dev-C++ 

1. เปิดโปรแกรม Dev-C++ จาก Start Menu หรอืไอคอนบน Desktop 
2. คลกิ File → New → Source File เพื่อสรา้งไฟลใ์หม ่

 
✅ ข ัน้ตอนท่ี 2: พิมพโ์ค้ด C++ ดงัน้ี 
#include <iostream>     // เรยีกใชไ้ลบรารสี าหรบัแสดงผล 
using namespace std;    // ใช ้namespace มาตรฐาน 
 
int main() { 
    cout << "Hello World!";   // แสดงผลขอ้ความ 
    return 0;                 // จบโปรแกรม 
} 

 
✅ ข ัน้ตอนท่ี 3: บนัทึกไฟล ์

1. ไปทีเ่มนู File → Save As 
2. ตัง้ชื่อไฟลว์า่ hello.cpp และเลอืกไดเรกทอรทีีต่อ้งการบนัทกึ 
3. คลกิ Save 

 
▶  ข ัน้ตอนท่ี 4: คอมไพลแ์ละรนั 

 คลกิปุ่ม Compile & Run (รปูจรวดสเีขยีว) หรอืกดปุ่ม F11 

 
  ผลลพัธท่ี์ได้ในหน้าต่าง Console: 
Hello World! 

 
✅ ค าอธิบายโค้ดแบบง่าย 

ส่วนของโค้ด ความหมาย 

#include <iostream> ใชส้ าหรบัแสดงผลดว้ย cout 

using namespace std; ยน่ชื่อฟังกช์นัจาก std::cout ใหเ้หลอืแค่ cout 

int main() ฟังกช์นัหลกัของโปรแกรม เป็นจุดเริม่ตน้ของการท างาน 

cout << "Hello World!"; แสดงขอ้ความ "Hello World!" ออกหน้าจอ 

return 0; ส่งค่ากลบั 0 เพื่อบอกวา่โปรแกรมจบอยา่งปกต ิ
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✅ โครงสร้างพื้นฐานของโปรแกรม Hello World 
+-----------------------------+ 
|      #include              | 
|      using namespace  | 
|      int main()             | 
|        cout << ...          | 
|        return 0;            | 
+-----------------------------+ 

 
 

สรปุ 
บทแรกของหนังสอืเล่มนี้มุ่งเน้นการปูพื้นฐานการใช้งานโปรแกรม Dev-C++ ส าหรบัผู้เริม่ต้น 

โดยครอบคลุมตัง้แต่การตดิตัง้และตัง้ค่าโปรแกรมอยา่งถูกตอ้ง การสรา้งและคอมไพลโ์ปรเจกต์แรก การ
ท าความเขา้ใจส่วนประกอบส าคญัของโปรแกรม C++ เช่น main() และ header files ไปจนถึงการ
ทดลองเขยีนโปรแกรม "Hello World!" เพื่อใหผู้อ่้านไดส้มัผสักบักระบวนการพฒันาโปรแกรมตัง้แต่ต้น
จนจบอยา่งครบถ้วน เป็นการเตรยีมความพรอ้มทีส่ าคญัก่อนเขา้สู่เนื้อหาเชงิลกึในบทต่อไป. 
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บทท่ี 2 
พ้ืนฐานภาษา C++  

(C++ Basic) 
 

เน้ือหา 

 พืน้ฐานภาษา C++ 
 ขอ้มลูเพิม่เตมิพืน้ฐานภาษา C++ (Extended) 
 ตวัแปรและชนิดขอ้มลูพืน้ฐานใน C++ 
 การใช ้cin และ cout ใน C++ 
 การใช ้cin และ cout ใน C++ — รายละเอยีดเพิม่ 
 ตวัด าเนินการ (Operators) ใน C++ 

 
  

บทน า 
ภาษา C++ เป็นภาษาคอมพิวเตอร์เชงิโครงสร้างและเชิงวตัถุที่ได้รบัความนิยมสูง เนื่องจากมคีวาม
ยดืหยุ่นในการเขยีนโปรแกรม ทัง้ในระดบัพื้นฐานและขัน้สูง ส าหรบัผู้เริม่ต้น การเข้าใจพื้นฐานของ
ภาษาถือเป็นสิง่ส าคญัยิง่ในการพฒันาไปสู่การสร้างโปรแกรมที่ซบัซ้อน โดยบทนี้มุ่งเน้นให้ผู้อ่านได้
เรยีนรู้เรื่องตวัแปร ชนิดขอ้มูล การรบั-ส่งค่าทางหน้าจอ และการใช้ตวัด าเนินการ ซึ่งเป็นโครงสร้าง
พืน้ฐานของทุกโปรแกรม C++ 

เนื้อหาเริม่ตน้จากการแนะน าตวัแปร (Variables) ซึง่ท าหน้าทีเ่กบ็ขอ้มลูในหน่วยความจ าของ
คอมพวิเตอร ์และชนิดขอ้มลูพืน้ฐานทีส่ าคญั เช่น int ส าหรบัจ านวนเตม็, float ส าหรบัเลขทศนิยม, char 
ส าหรบัตวัอกัษร และ bool ส าหรบัค่าความจรงิ (true/false) การเลอืกใชช้นิดขอ้มลูอยา่งเหมาะสมจะ
ช่วยใหโ้ปรแกรมท างานไดอ้ยา่งมปีระสทิธภิาพและปลอดภยัจากขอ้ผดิพลาด 

จากนัน้ผู้อ่านจะได้เรยีนรู้การใช้งานค าส ัง่ cin และ cout ซึ่งใช้ในการรบัขอ้มูลจากผู้ใช้และ
แสดงผลลพัธอ์อกทางหน้าจอ โดย cin ท าหน้าทีร่บัค่าจากคยีบ์อร์ด และ cout แสดงขอ้มูลไปยงัหน้าจอ 
ซึง่ทัง้สองค าส ัง่นี้เป็นเครื่องมอืหลกัในการโตต้อบกบัผูใ้ชง้าน 

ทา้ยทีสุ่ดในบทนี้ ผูอ่้านจะไดศ้กึษาการใชต้วัด าเนินการ (Operators) เช่น เครื่องหมายค านวณ
พื้นฐาน +, -, *, /, % รวมถึงการเพิม่ค่าหรอืลดค่าด้วย ++ และ -- ซึ่งเป็นสิง่ที่ขาดไม่ได้ในการสร้าง
โปรแกรมเชงิค านวณหรอืเชงิเงือ่นไข เนื้อหาในบทนี้จะเป็นพืน้ฐานส าคญัทีส่ง่เสรมิความเขา้ใจของผูอ่้าน
ในบทถดัไปซึง่มคีวามซบัซอ้นมากยิง่ขึน้. 
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2. พื้นฐานภาษา C++ 

 
2.1 ตวัแปรและชนิดข้อมลูพื้นฐาน 

 ตวัแปร (Variable) คอืพืน้ทีใ่นหน่วยความจ าทีเ่กบ็ขอ้มลู 
 ชนิดข้อมลู (Data Types) ทีใ่ชบ่้อยใน C++ ไดแ้ก่: 

ชนิดข้อมลู ค าอธิบาย ขนาด (ประมาณ) 

int จ านวนเตม็ เช่น 10, -3, 0 4 bytes 

float จ านวนทศนิยม เชน่ 3.14, -0.5 4 bytes 

char ตวัอกัษร เช่น 'A', 'b', '9' 1 byte 

bool ค่า True หรอื False 1 byte 

 
2.2 การประกาศตวัแปร 
int age = 20;           // ตวัแปรเกบ็เลขจ านวนเตม็ 
float pi = 3.14;        // ตวัแปรเกบ็เลขทศนิยม 
char grade = 'A';       // ตวัแปรเกบ็ตวัอกัษร 
bool isPass = true;     // ตวัแปรเกบ็ค่าบลูนี (จรงิ/เทจ็) 

 
2.3 การใช้ cin และ cout ส าหรบัรบัและแสดงผลข้อมลู 

 cout ใชแ้สดงผลขอ้ความหรอืค่าตวัแปรออกหน้าจอ 
 cin ใชร้บัค่าจากผูใ้ช ้

ตวัอย่างโปรแกรม: รบัข้อมลูและแสดงผล 
#include <iostream> 
using namespace std; 
 
int main() { 
    int number; 
    cout << "Enter a number: ";    // แสดงขอ้ความ 
    cin >> number;                 // รบัค่าจากผูใ้ชเ้กบ็ในตวัแปร number 
 
    cout << "You entered: " << number << endl;  // แสดงผลตวัแปร 
    return 0; 
} 
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2.4 การใช้ตวัด าเนินการ (Operators) 

ตวัด าเนินการ ความหมาย ตวัอย่าง ผลลพัธ ์

+ บวก 5 + 3 8 

- ลบ 5 - 3 2 

* คณู 5 * 3 15 

/ หาร 10 / 2 5 

% หารเอาเศษ (Modulo) 10 % 3 1 

++ เพิม่ค่า 1 (Increment) int a = 5; a++; 6 

-- ลดค่า 1 (Decrement) int a = 5; a--; 4 

 
2.5 ตวัอย่างโปรแกรมรวมการใช้ตวัแปร, cin, cout และตวัด าเนินการ 
#include <iostream> 
using namespace std; 
 
int main() { 
    int a, b; 
 
    cout << "Enter first number: "; 
    cin >> a; 
 
    cout << "Enter second number: "; 
    cin >> b; 
 
    cout << "Sum: " << (a + b) << endl; 
    cout << "Difference: " << (a - b) << endl; 
    cout << "Product: " << (a * b) << endl; 
    cout << "Quotient: " << (a / b) << endl; 
    cout << "Remainder: " << (a % b) << endl; 
 
    a++;  // เพิม่ค่า a ทลีะ 1 
    cout << "Incremented first number: " << a << endl; 
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    b--;  // ลดค่า b ทลีะ 1 
    cout << "Decremented second number: " << b << endl; 
 
    return 0; 
} 

 
2.6 ค าอธิบายผลการรนั 
สมมตผิูใ้ชก้รอกค่า 10 และ 3 
Enter first number: 10 
Enter second number: 3 
Sum: 13 
Difference: 7 
Product: 30 
Quotient: 3 
Remainder: 1 
Incremented first number: 11 
Decremented second number: 2 

 
ข้อมูลเพ่ิมเติมพื้นฐานภาษา C++ (Extended) 

 
1. ตวัแปร (Variables) และชนิดข้อมลู (Data Types) เพ่ิมเติม 

ชนิดข้อมลู ค าอธิบาย 
ขนาด

โดยประมาณ 
ตวัอย่างค่าท่ีเกบ็ได้ 

int จ านวนเตม็ 4 bytes 0, -1, 123, 10000 

float 
จ านวนทศนิยมความแม่นย า
ปานกลาง 

4 bytes 3.14159, -0.5 

double จ านวนทศนิยมความแม่นย าสงู 8 bytes 3.1415926535, -0.123456789 

char ตวัอกัษร 1 ตวั 1 byte 'A', 'b', '9', '?' 

bool ค่าความจรงิ (จรงิ/เทจ็) 1 byte true, false 

long, long 
long 

จ านวนเตม็ขนาดใหญ่ (มากกวา่ 
int) 

8 bytes (long 
long) 

1234567890123 
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ชนิดข้อมลู ค าอธิบาย 
ขนาด

โดยประมาณ 
ตวัอย่างค่าท่ีเกบ็ได้ 

unsigned int จ านวนเตม็บวกเท่านัน้ 4 bytes 
0, 100, 4294967295 (ค่าบวก
เท่านัน้) 

 
2. การประกาศตวัแปรและการก าหนดค่า 

 การประกาศตวัแปรเปล่า (ยงัไม่ก าหนดค่าเริม่ตน้) 
int age;      // ตวัแปรชื่อ age ประเภทจ านวนเตม็ (ค่าเริม่ตน้จะเป็นค่าขยะ) 

 การประกาศพรอ้มก าหนดค่าเริม่ตน้ 
int age = 25; 
float pi = 3.14f;   // ตวั f เพื่อบอกวา่เป็น float literal 
double e = 2.71828; 
char ch = 'Z'; 
bool isTrue = false; 

 การประกาศหลายตวัแปรพรอ้มกนั 
int x = 0, y = 1, z = 2; 

 
3. การใช้ cin รบัข้อมลูหลายชนิด 
#include <iostream> 
using namespace std; 
 
int main() { 
    int age; 
    float height; 
    char grade; 
 
    cout << "Enter your age: "; 
    cin >> age; 
 
    cout << "Enter your height (in meters): "; 
    cin >> height; 
 
    cout << "Enter your grade (A-F): "; 
    cin >> grade; 
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    cout << "Age: " << age << ", Height: " << height << ", Grade: " << grade << endl; 
 
    return 0; 
} 
หมายเหต:ุ 

 cin จะรบัขอ้มลูจนถงึช่องวา่งหรอื Enter 
 รบั char จะรบัแค่ตวัอกัษรตวัเดยีว 
 หากตอ้งการรบัขอ้ความหลายค าหรอืบรรทดัตอ้งใช ้getline() (ต่อไปสามารถสอนได)้ 

 
4. ตวัด าเนินการ (Operators) ในเชิงลึก 

ประเภทตวัด าเนินการ ตวัอย่าง ค าอธิบาย 

Arithmetic Operators +, -, *, /, % บวก, ลบ, คณู, หาร, หารเอาเศษ 

Increment/Decrement ++, -- เพิม่หรอืลดค่าทลีะ 1 

Assignment Operators =, +=, -=, *=, /=, %= ก าหนดค่าและบวก-ลบ-คณู-หารแบบยอ่ 

Comparison Operators ==, !=, <, >, <=, >= เปรยีบเทยีบค่า 

Logical Operators &&, ` 
 

 
5. ตวัอย่างการใช้ตวัด าเนินการเพ่ิม 
#include <iostream> 
using namespace std; 
 
int main() { 
    int a = 5, b = 3; 
 
    a += 2;  // เท่ากบั a = a + 2; a = 7 
    b *= 4;  // เท่ากบั b = b * 4; b = 12 
 
    cout << "a = " << a << endl;  // 7 
    cout << "b = " << b << endl;  // 12 
 
    bool result = (a > b) && (b != 0); 
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    cout << "Result of logical expression: " << result << endl;  // false (0) 
 
    return 0; 
} 

 
6. การแสดงผลของ bool ใน C++ 

 ค่า true จะแสดงเป็น 1 
 ค่า false จะแสดงเป็น 0 

ถ้าตอ้งการแสดงเป็นค าวา่ true หรอื false แทนตวัเลข ใช ้
cout << boolalpha; 
cout << "Result: " << result << endl; 

 
7. หมายเหตเุก่ียวกบัการหารจ านวนเตม็ 

 ถ้าใช ้/ กบัตวัแปร int จะท าการหารแบบตดัเศษ (integer division) 
int x = 7, y = 2; 
cout << x / y << endl;  // ผลลพัธค์อื 3 (ไม่ใช่ 3.5) 
ถ้าตอ้งการผลลพัธท์ศนิยม ตอ้งใช ้float หรอื double เช่น 
float x = 7.0f, y = 2.0f; 
cout << x / y << endl;  // ผลลพัธค์อื 3.5 

 
ตวัแปรและชนิดข้อมูลพื้นฐานใน C++ 
1. ตวัแปร (Variable) 

 คอืชื่อทีเ่ราใชแ้ทนพืน้ทีเ่กบ็ขอ้มลูในหน่วยความจ า 
 ก่อนใชง้านตอ้งประกาศชนิดขอ้มลูและชื่อตวัแปรเสมอ 
 ตวัแปรสามารถเกบ็ค่าต่างๆ ทีก่ าหนดไดใ้นโปรแกรม 

 
2. ชนิดข้อมลูพื้นฐานหลกั 

ชนิดข้อมลู ค าอธิบาย ขนาด (โดยประมาณ) ตวัอย่างค่า 

int เกบ็เลขจ านวนเตม็ (ไมม่จีุดทศนิยม) 4 bytes 10, -5, 0 

float เกบ็เลขทศนิยมแบบความแม่นย าปานกลาง 4 bytes 3.14, -0.5 

char เกบ็ตวัอกัษร 1 ตวั 1 byte 'A', 'z', '9' 

bool เกบ็ค่า จริง (true) หรอื เทจ็ (false) 1 byte true, false 
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